关于在Ubuntu18.04安装网易云音乐,出现缺少libqt5libqgtk2依赖的解决方法

作为一个程序员,会有听着歌曲撸代码的习惯,所以肯定要安装一个音乐播放器,而首选就是网易云音乐。但是在 网易云音乐官网 下载的Ubuntu版网易云音乐的deb安装包在执行安装命令sudo dpkg -i [包名]的时候会出现依赖包libqt5libqgtk2未安装的问题,接下来使用常规方法sudo apt-get install libqt5libqgtk2去安装这个包的时候又会出现另外一个问题。

qt5-style-plugins 已经取代了libqt5libqgtk2,libqt5libqgtk2可能已经被废弃,无法安装。也就是qt5-style-plugins已经包括了libqt5libqgtk2所能提供的功能,apt源已经不需要libqt5libqgtk2了,然而网易云的软件包却没有更新依赖包,也就是网易云音乐的依赖指向的仍是libqt5libqgtk2,而非最新的qt5-style-plugins。一种方法是在网上下载libqt5libqgtk2,手动安装,但是可能会出现新的依赖问题;第二种方法是修改DEB包的依赖。但是这里不介绍修改依赖的办法,感兴趣的可以去 https://www.jianshu.com/p/7dc2c6052c1c 查看。

这里直接把做好的新的包分享给大家:

链接: https://pan.baidu.com/s/1XpSqMy8ttM2xlbR-B3XylQ 提取码: bppd

获取到安装包之后,直接运行命令安装,如果还出现依赖未安装的情况,执行以下命令

sudo apt-get install -f

最后一步执行:

sudo gedit /usr/share/applications/netease-cloud-music.desktop

然后在netease-cloud-music %U后添加一个空格,再添加--no-sandbox保存即可

上一篇:Linux tar压缩和解压缩命令详解

下一篇:搭建简易静态文件http服务器